WWW.JLSNET.CO.UK

Birdstep Mobile IP

Author: James Saunders Date: Wed, 4 Jun 2003 13:00:00 CEST

Since my University final year project subject is about mobile network roaming, I have been interested in a few MobileIP solutions including Accenture, ipUnplugged, Adjungo, Icomera and Birdstep.

The Birdstep Intelligent Mobile IP Client has followed an open, standards-based approach to provide seamless roaming for operators and enterprises. Birdstep work very closely with Cisco in providing the know-how into improving the VPN roaming model. The Birdstep solution requires a piece of software running on a mobile client, and the following Cisco config:

Topology


Requirements

Home IP Agent must be running on Cisco router. This configuration requires additional subnet, /30 is OK. The IOS image for the router must be 12.2.13T with IP Plus or greater.

Config

note: you may need to adjust the configure to fit into your setup. The blue part of the configuration is the part that most likely you would need.

version 12.2
!
hostname router1
!
ip subnet-zero
!
ip dhcp excluded-address 10.10.1.1 10.10.1.200
ip dhcp excluded-address 10.21.1.1 10.21.1.200
!
ip dhcp pool Net-10.10.1.0
  network 10.10.1.0 255.255.255.0
  default-router 10.10.1.10
!
ip dhcp pool Net-10.21.1.0
  network 10.21.1.0 255.255.255.0
  default-router 10.21.1.10
!
!
interface Loopback1
  description ==== Home Agent Address used by MN =====
  ip address 200.1.1.10 255.255.255.255 
  !
interface FastEthernet0/0
  description ==== Wired Net =====
  ip address 172.19.192.200 255.255.255.0 secondary
  ip address 10.21.1.10 255.255.255.0
  duplex auto
  speed auto
!
interface Ethernet1/0
  description ==== Air Net =====
  ip address 10.10.1.10 255.255.255.0
  half-duplex
!
router mobile
!
router ospf 100
  log-adjacency-changes
  redistribute mobile subnets
  network 10.10.1.0 0.0.0.255 area 2
  network 10.21.1.0 0.0.0.255 area 2
  network 200.1.1.10 0.0.0.0 area 2
!
ip classless
ip http server
ip pim bidir-enable
ip mobile home-agent
ip mobile virtual-network 20.1.1.0 255.255.255.0
ip mobile host 20.1.1.1 20.1.1.10 virtual-network 20.1.1.0 255.255.255.0
ip mobile secure host 20.1.1.1 20.1.1.10 spi 100 key 
      hex 12345678123456781234567812345678 algorithm md5 mode prefix-suffix
!
end

For More information

 
Site By JLSaunders http://www.jlsnet.co.uk/ Copyright © JLSaunders 2010